TinyTinyRSS(TT-RSS)をアップデートしたらエラーになった#2

今日も今日とてgit pullして、二日連続同じトラブルにあったなり。

f:id:ntoh:20210226114804p:plain

とくにerror.log等にも手がかりがないので、エラーメッセージから辿ってみた。

: classes/handler/public.php:848
msgid "Your access level is insufficient to run this script."
msgstr "あなたの権限では、このスクリプトを実行できません。"

該当の部分はここっぽい。

if (!Config::get(Config::SINGLE_USER_MODE) && $_SESSION["access_level"] < 10) {
    $_SESSION["login_error_msg"] = __("Your access level is insufficient to run this script.");
    $this->_render_login_form();
    exit;
     }

access_levelをあげれば通るっぽいので(無茶な理論)、直接DB側で変更したらなんとか入れるようになった。

f:id:ntoh:20210226114845p:plain

ちなみにgit pullでアップデートした結果、データベースのバージョンアップ作業が求められていたっぽいので、たんに管理者権限ではいればよかったっぽいです。(管理者はaccess_level=10)

/* 全体の横幅 */ #content { width: 1200px; } /* 記事の横幅 */ #main { width: 960px; }